Problema 32 bits de XAMPP en Linux

En éste post, quiero hablar sobre un problema que me ha pasado con XAMPP al actualizar a Fedora 29.

Cuando fui a iniciar XAMPP por linea de comandos, me salió el siguiente error:

Lo primero que pensé que al tener yo una versión antigua de XAMPP por un lado y por otro lado haber actualizado a Fedora 29 era que tendría que actualizar el XAMPP. Bajé la versión mas nueva para Linux, con especial interés en la versión de 64 bits.

Para mi sorpresa, me seguía dando el mismo error. Tras estar mirando, el problema reside en que aunque te descargues la versión de 64 bits, algunas partes siguen necesitando sistema de 32 bits y por eso da el error. Para solventarlo, hay que “engañar” a XAMPP para que crea que tenemos un sistema de 32 bits. Para ello hemos de meternos en la línea de comandos para editar una parte de la solución:

Obviamente, se hace con root. Una vez abierto el archivo, tenemos que buscar estas dos lineas:

Para poder solucionar el problema, es quitar el simbolo # de la primera línea y ponérselo al otro. Quedaría así:

Con ésto, solventaríamos el problema.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Si continuas utilizando este sitio aceptas el uso de cookies. Puedes obtener más información

Los ajustes de cookies de esta web están configurados para "permitir cookies" y así ofrecerte la mejor experiencia de navegación posible. Si sigues utilizando esta web sin cambiar tus ajustes de cookies o haces clic en "Aceptar" estarás dando tu consentimiento a esto.

Cerrar

www.000webhost.com